pasUNITY Enterprise Suite .NET Framework 4.7 Update Notice

Written By Gary Fletcher

Blogs pasUNITY Products

New versions of all pasUNITY Enterprise Suite components have been released today and they all have new prerequisites and a new list of supported operating systems.

What exactly is changing?

Previously, all of our products had a dependency on the Microsoft .NET Framework 4.0.3 or higher. That dependency has been changed and now requires the Microsoft .NET Framework 4.7 or higher.   The Microsoft .NET Framework 4.7 is not supported on some of the operating systems that 4.0.3 was supported on and as such those operating systems will no longer be supported.

Why are you doing this?

Previously, all of our products had targeted the Microsoft .NET Framework 4.0.3.  This allowed us to support the widest array of operating systems including everything from Windows Server 2003 thru Windows Server 2016 and Windows XP thru Windows 10 using a base set of features and functionality common to all platforms.

Unfortunately, this lowest common denominator approach was inhibiting us from enhancing our security infrastructure and building some features that required capabilities in the latest .NET frameworks.  The most important change is that our client applications will be able to communicate with the pasPortal Web Service infrastructure using the protocols, ciphers, hashes, and key exchanges that are available and enabled on your operating system and not just those that were available when .NET 4.0.3 shipped a decade ago.  This makes it possible to build a more secure infrastructure and take advantage of new TLS 1.2 security protocols and future-proofs the soluttion to take advantage of TLS 1.3 once it makes it into Windows.

There is a fairly large initiative going on right now to deprecate SSL 3.0, TLS 1.0, and TLS 1.1 and support TLS 1.2.  This framework update makes it possible for us to do that.

How does this impact me?

New versions of all products released today will no longer run on the following operating systems:
  • Windows Server 2003
  • Windows Server 2008
  • Windows XP
  • Windows Vista
  • Window 8
They will still continue to run on the following operating systems though:
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows 7
  • Windows 8.1
  • Window 10 version 1607 or higher
You will note that all of the operating systems for which we are ending support that Microsoft has already done this themselves.

What if I still have pasUNITY products running on these unsupported operating systems?

You can keep running your existing installed products on these unsupported operating systems but they will not be supported and there will be no future updates for these platforms.
You are also going to need to install some updates and make some changes to the local registry if you want them to continue to be able to communicate with the pasPortal.  You can read about these manual steps here.

Are there any new features?

Depending on the product: yes.  Please see the product specific announcements on this blog for more details on changes and features.

Follow Us

2024-05-26 07:15:16
© 2003 - 2024 pasUNITY, Inc. | Terms Of Use | Privacy Statement